Tags GE

Researchers warn of critical vulnerability in GE anesthesia machines

by Sean Lyngaas • 4 months ago

The research points to a broader problem of insecure firmware used in medical devices, according to CyberMDX.

TwitterFacebookLinkedInRedditGoogle Gmail